Okt
16
2012

Das Öffnen des Archivs benötigt Minuten

Kategorie: Fehlerbehebung
Support-Recherche: Archiv öffnen


Nach Umstellung auf einen neuen Server dauert es bei einigen Office Manager-Archiven mehrere Minuten, bis diese geöffnet sind. In der Statuszeile steht, dass die Layoutdatei geladen wird. Ein vernünftiges Arbeiten ist so nicht möglich, wie kommen wir wieder zur gewohnten schnellen Ladezeit?

Kurzfassung

Die betroffenen Layoutdateien enthielten Verweise zum alten Dateiserver: Bilddateien waren mit UNC-Pfad angegeben. Nachdem diese entfernt wurden, öffneten die Archive wieder innerhalb einer Sekunde.

Ausführlich

Erscheinungsbild

Beim Programmstart oder beim Wechsel zu einem anderen Dokumentenarchiv reagiert der Office Manager für viele Sekunden nicht, in diesem Fall sogar für 2 Minuten. In der Statuszeile steht „Lade Layout (Dateiname)…“:

Statuszeile "Lade Layout..."

Manche Archive laden wie gewohnt schnell, andere benötigen eine ungewöhnlich lange Zeit. Mit der Datenbankgröße scheint es nichts zu tun zu haben, auch sehr kleine Datenbanken laden extrem langsam.

Ursache

Mit Hilfe des Layoutdesigners wurden in einigen Archivdatenbanken Bilder platziert. Der Bilddateiname ist mit vollständigem UNC-Pfad angegeben, im obigen Beispiel „\\berta\ServerDaten\…“. Dieser Server wurde jetzt aber ersetzt und der neue Server hat einen anderen Namen.

Wenn Office Manager die Layoutdatei öffnet, prüft er, ob die jeweilige Bilddatei vorhanden ist. Windows benötigt bei UNC-Pfaden viel Zeit um festzustellen, dass der Computer im Netzwerk nicht vorhanden ist. Office Manager wartet auf die Antwort, dass der Computer und somit die Datei fehlt.

Lösung

Die Layoutdateien müssen angepasst werden. Dies kann mit dem Designer erfolgen oder auch mit einem Texteditor direkt in der .lay-Datei. Alle Verweise zum alten Server bitte durch den neuen Servernamen ersetzen. Wenn die Bilddatei im Layoutverzeichnis gespeichert ist, dann müssen Sie übrigens keinen Pfad angegeben werden, der Dateiname „bild.jpg“ genügt.

Testmöglichkeit

Anwender der Enterprise-Edition können zum Test auch kurz den Terminalserver-Modus aktivieren, Bilder werden dann nicht geladen. Wenn das Problem in diesem Modus nicht auftritt, dann liegt es entweder an den Grafiken oder an Lese- und Schreiboperationen der Windows-Registrierungsdatenbank.

Siehe auch

Das Schließen des Archivs benötigt 1 Minute


 

Noch keine Kommentare

Eigenen Kommentar schreiben oder eine Rückfrage stellen

Ihre E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind markiert *

Sie können folgende HTML-Tags verwenden: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>